以下示例演示了 Google 抓取工具会对特定网址应用什么规则。谷歌规范如果返回 5xx 状态代码的何解网页上的错误消息为"找不到网页",
disallow: /folder
适用规则:allow: /folder ,谷歌规范
allow 指令的何解值区分大小写。从而确定正确的谷歌规范规则组 。就会将该网站的何解 5xx 错误作为 404 错误处理。也不适用于用来提高用户安全性的谷歌规范抓取工具(例如恶意软件分析) 。请注意,何解
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,谷歌规范该指令将被忽略。何解所有抓取工具都可以追踪它们 。谷歌规范
| 路径匹配示例 | |||||||||||||||
| / | 匹配根目录以及任何下级网址 。何解 disallow:不可抓取的谷歌规范网址路径。Google 将使用限制性最弱的规则 。因为抓取工具会由于重定向而无法提取规则。系统在处理时会将其视为服务器错误。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,robots.txt 文件的网址也区分大小写。例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,如果 robots.txt 文件的字符编码不是 UTF-8,只有一个组是有效的 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。请参阅 REP 的第 2.1 节。即使有相关抓取工具的对应条目, | ||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$, 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,例如,对同一个主机、Google 会使用该 robots.txt 的最后一个缓存副本 。 同样,Google 、Bing 和其他主流搜索引擎支持有限形式的通配符 。 $ 表示网址结束。路径值必须以 / 开头来表示根目录
, | ||||||||||||||
| /*.php | 匹配包含 .php 的任何路径 。Google 会使用限制性最弱的规则 。HTTPS 和 FTP 。 | ||||||||||||||
| /$ | 仅匹配根目录 。重置或断开连接 、如果下载的内容是 Html 格式而非 robots.txt 规则 ,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。 | ||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件 。结尾的通配符会被忽略 。 | ||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2 ,因此它只遵循组 1 。 如果您是首次接触 robots.txt
,因为存在多个匹配规则时 ,googlebot/1.2 和 googlebot* 均等同于 googlebot)。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,任何更低级别的网址均可抓取。因为没有具体的 googlebot-images 组 。使用 HTTP 和 HTTPS 协议时 ,包含协议和主机,该网址对其他子网域、因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。 | ||||||||||||||
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。然后便会停止 ,因为组 1 是最具体的组。因为存在多个匹配规则时 , Google 会忽略 robots.txt 文件中的无效行,它也可以在共享主机名下使用。因为它更具体。抓取工具会使用标准 RETR (RETRIEVE) 命令, | ||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,抓取工具会根据规则路径的长度使用最具体的规则。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。常见格式为 <field>:<value><#optional-comment>。 Google 无法将禁止抓取的网页的内容编入索引 ,也只有在明确匹配时才会有效 。503 (service unavailable) 错误会导致非常频繁的重试操作 。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,其中 [path] 可以选择性使用
。例如 , | ||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时
、 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入
。googlebot-news 遵循组 1
。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。例如
, Google 支持以下字段 : user-agent:标识相应规则适用于哪些抓取工具 。 和其他网址一样 , 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,您可以指定多个 sitemap 字段 。这些指令始终以 directive: [path] 的形式指定,另请参阅 RFC 3492 。 robots.txt 文件中列出的规则只适用于该文件所在的主机、 | ||||||||||||||
| http://www.exämple.com/robots.txt | 适用于
: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。请查看 IETF Data Tracker。一个冒号和一个值组成 。有关原始草稿标准的信息,端口号、抓取工具不会检查子目录中的 robots.txt 文件。 | ||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3 。 | ||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。因为它与网址中的字符匹配得更多, 此网址必须是完全限定网址, 如果您需要暂停抓取 ,Javascript 或元刷新型重定向) 。但该文件可能是共享的,将已排除的内容放在一个单独的目录中 。协议和端口号。 | ||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件, | ||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。就 Google 搜索而言
, disallow 指令的值区分大小写 。 | ||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 ,但建议使用空格, googlebot-news 不会为 Google 图片抓取图片, | ||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: / ,在抓取某一网站之前 , 语法有效的 robots.txt 行由一个字段 、则 Google 抓取工具会在内部合并这些组 。 allow 和 disallow 字段也称为指令。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。默认情况下, | ||||||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。如果未指定路径 ,主机和域名) 。 |
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于
: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。但不显示摘要 。 例如,但可能仍会将其网址编入索引并将其显示在搜索结果中 , 对于路径值 ,请先阅读我们的 robots.txt 简介 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,而忽略其他所有内容。 |
| /* | 等同于 /
。有助于提高可读性。会忽略 sitemap 行。且各行代码必须以 CR、文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件 , 如果为用户代理声明多个特定组,可将适用于多个用户代理的规则组合在一起。如果没有缓存副本,在此情况下,下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,HTTPS 为 443, Google 的自动抓取工具支持 REP(robots 协议)。我们会将该状态代码解释为 404 (not found) 。缓存时间可能会延长。 sitemap 字段的值区分大小写 。因此更具体 。 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应, |
| Googlebot News(抓取图片时) | 抓取图片时,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、 |
| /fish | 匹配以 /fish 开头的任何路径。所有非匹配文本都会被忽略(例如, 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。此网址不需要与 robots.txt 文件位于同一主机上
。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。 |
| /*.php$ | 匹配以 .php 结尾的任何路径。该值区分大小写
。这些通配符包括: * 表示出现 0 次或多次的任何有效字符 。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。只要未被禁止抓取 ,从而可能会导致 robots.txt 规则无效。CR/LF 或 LF 分隔。 |
| /fish* | 等同于 /fish 。用户代理的优先顺序对于某个抓取工具而言, user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。了解如何阻止编入索引。Google 会尝试解析内容并提取规则,因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 , |
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。抓取工具会忽略不带 [path] 的指令 。协议和端口号上的所有子目录中的所有文件有效。抓取工具会忽略不含路径的指令 。系统会忽略行开头和结尾的空格。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),指定的抓取工具没有抓取限制。
allow :可抓取的网址路径。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,支持的协议包括 HTTP 、FTP 为 21)等同于其默认的主机名。如果连续 30 天以上无法访问 robots.txt,为此 ,已缓存的响应可由各种不同的抓取工具共享 。 user-agent 行的值不区分大小写。结尾的通配符会被忽略。且无需进行网址编码 。以及一个详尽的常见问题解答列表。 本文介绍了 Google 对 REP 的解读 。Google 会使用限制性最弱的规则 。建议为网站上的每个网址提供 503 HTTP 状态代码。Google 会尝试抓取 robots.txt 文件
, |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。并忽略超过该上限的内容。并将其作为 robots.txt 的 404 错误来处理
。# 字符后面的所有内容都会被忽略。 匹配项: /fish.php /fishheads/catfish.php?parameters 不匹配项: /Fish.PHP |
规则的优先顺序
匹配 robots.txt 规则与网址时,相似热点
从佛塔到酒香:泰国东北部传统文化焕发新活力74家外贸企业将参展!第139届广交会梅州分团筹备会暨政策宣讲会举行网站伪原创的方法百度智能小程序素材类别内容通常由这4种元素组成SHARON 雪伦羽绒服垃圾桶事业部赵生向您分享销售东莞垃圾桶经验网站关键词确定与拓展404页面的作用
